Child theme problem

Forums Forums SwiftThemes Support Child theme problem

Tagged: 

This topic contains 2 replies, has 2 voices, and was last updated by  Art Munson 2 weeks, 1 day ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #34662

    Art Munson
    Participant

    Hi Satish,

    Trying to get a child theme to work.

    I’m making a slight modification to post-single.php. I’m inserting

    <?php if (in_category(array(25, 3, 161, 132, 41, 136, 26, 177, 133, 176, 243, 85, 134))) {
    gdrts_posts_render_rating(array(‘echo’ => true));
    } ?>

    just before

    <?php endif; ?>

    Everything works correctly when used in post-single.php in the swift-premium directory.

    I created the directory swift-premium-child directory. Created a non funcioning style.css file and created a functions.php file with the following code:

    <?php

    //* Code to import style sheets

    add_action( ‘wp_enqueue_scripts’, ‘enqueue_parent_styles’ );

    function enqueue_parent_styles() {
    wp_enqueue_style( ‘parent-style’, get_template_directory_uri().’/style.css’ );
    }

    The problem is that when switched to the child theme I lose the left and right sidebars and they are stacked one right after the other. As I mentioned everything displays properly when I modify post-single.php in the swift-premium directory but not in the swift-premium-child directory.

    Any clue on what I need to do?

    Thank you

    #34664

    Satish Gandham
    Keymaster

    Don’t load the stylesheet separately, swift already handles it.

    #34665

    Art Munson
    Participant

    Thanks Satish, that fixed it. Only have <?php in functions.php

    Looking forward to trying the new theme update!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.