how to remove swift theme image from above blog posts?

Forums Forums SWIFT Themes Support how to remove swift theme image from above blog posts?

This topic contains 12 replies, has 6 voices, and was last updated by  Tinisha Johnson 3 years, 6 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
URL:
Version:
  • Author
    Posts
  • #15774

    leighva
    Spectator

    I only see it above the first two, how do I remove? Thanks!!

    Blog | Deepwood Vet

    #20143

    invernessGiGs
    Spectator

    i suspect that you have images turned on for them, so you need to go through the swift customisation ? on home page to remove

    #20137

    Skippy
    Spectator

    The default swift theme image can be changed from the gray ‘swoop’ to an image of your choice.

    This means that when you do not manually add an image to a post, your own default image will show instead of the Swift Theme’s image.

    The image you want to substitute is located here:

    Open the theme’s files. I do this through cPanel, other use something like filezilla.

    So for me, in cPanel, I would go to ‘public_html’, then ‘my site.com’, then ‘wp-content’, then ‘Themes’, then your version of Swift.

    After opening the Swift Theme files you will see a folder named ‘Images’ and the one you want to edit/replace is the ‘default.jpg’

    The ‘default.jpg’,in my version, says, “PNG image data, 580 x 290, 8-bit colormap, non-interlaced”.

    Make sure you stay within the dimensions of the original when replacing the image and make sure you have it named the same as the original ‘default.jpg’. You can play around with dimensions under 580 x 290, but I would be careful going larger than those parameters.

    #20142

    leighva
    Spectator

    Thank you! I didn’t see anything customization, so I assume I can go into cpanel and just delete that image?

    #20138

    Skippy
    Spectator

    If you do not want a default image on your site, then I would, in lieu of deleting the default.jpg, I would just rename it in cPanel. Name it something like defaultbak.jpg. That way, it will not show on your site. Down the road, should you want a default image, you just add it to cPanel as default.jpg, deleting or renaming you defaultbak.jpg.

    Renaming a file helps to locate where the file is for future use. If you delete it it is likely to be more of a problem to replace it, remembering where it goes, etc. Renaming makes it invisible, yet acts as a placeholder.

    #20144

    robbie
    Spectator

    I made a new default image smaller than the 580 x 290 and the theme automatically sets it at 580 x 290. Not a problem for me just a heads up.

    #20145

    Tinisha Johnson
    Spectator

    I don’t understand these instructions on how to remove the default image. I bought a domain through godaddy.com and I use WordPress as the site to that domain. I selected a Swift Theme. How do I locate these files you are referring to on WordPress? I’m trying to get rid of the default image as well. And I do have an image selected in my post.

    #20139

    Skippy
    Spectator

    I use Hostgator as a site host. They use cPanel for file maintenance.

    You purchased hosting space from Godaddy, or just a name? Does godaddy use cPanel as a hosting interface? Do you use wordpress.com or .org?

    #20146

    Tinisha Johnson
    Spectator

    I purchased hosting and the domain name from GoDaddy.com. I use wordpress.org. Maybe I will go to GoDaddy.com and see if I can find the cPanel. Maybe that’s the problem, but if you have any other suggestions let me know. Going there now to figure this out. Thanks for the tip.

    #20147

    Tinisha Johnson
    Spectator

    Alright thank you Skippy. This worked. It didn’t occur to me to go to my hosting at godaddy.com. duh… I guess I thought I had to do everything on the WordPress.org site. Thank you so much. I renamed the default.jpg like your instructions indicated to defaultbak.jpg and then I renamed one of my own photos I had on my desktop to default.jpg and uploaded it. Worked like a charm….I was so frustated before …thank you so much for your help.

    #20140

    Skippy
    Spectator

    Are you familiar with accessing the theme files? I am assuming that you have a hosting plan. The file you want is in there.

    Or,… try you can try this.

    Find the theme files that you downloaded from Satish.

    Open the Swift theme.

    See the ‘admin’ folder, open it.

    Find ‘images’ folder, open it.

    Find ‘ swift-logo’ file. (There are two logo image files. The one you want is the file without the ‘-‘ at the end of it.)

    That is the file with the default swoop image in it.

    Take your image, make sure it is named the exact same thing as the default ‘swift-logo.png‘ and replace the default image with your own.

    Now you have the theme files changed and you will need to reinstall the theme so that your new default image shows on your site.

    #20136

    moku999
    Spectator

    I encountered this on version 5.74. Go to Swift options –> Home & Archives Pages –>Number of full length posts (change this to 0)

    #20141

    Skippy
    Spectator

    I am glad that you found a way to replace the default image, tinisha. Sometimes this website stuff, especially going into the cPanel, or web-host files, can be daunting.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.