Upgraded to Swift Premium Which Broke WP Super Cache!?

Forums Forums SWIFT Themes Bug report and suggestions. Upgraded to Swift Premium Which Broke WP Super Cache!?

This topic contains 4 replies, has 2 voices, and was last updated by  James B 2 years, 9 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
URL:
Version:
  • Author
    Posts
  • #16190

    James B
    Member

    I had been using the free version of Swift for about a year. I was so pleased I decided to upgrade to the premium version. I upgraded yesterday and spent the afternoon setting up my site etc.

    Everything is fine except the WP Super Cache plugin now does not work. I have used Super Cache without issue along with the free swift theme with no issues. As soon as I upgraded to the premium version of Swift I’ve had issues. Of course I’ve done the basics. I’ve tried deleting and reinstalling WP Super Cache which didn’t work. I’ve tried deleting all other plugins except for WP super cache and it still doesn’t work. I’m just confused on what the issue could be because I really haven’t changed anything except upgrading to Swift Premium.

    As a workaround I tried temporarily installing W3 Total Cache which appeared to work. However, I prefer WP Super Cache because I’m on shared hostin. Being on Lunar Pages shared hosting, W3 Total Cache has a ton of bells and whistles that just do me no good.

    In the past I’ve compared the performance of my sites and server load using W3 and Super cache and WP Super Cache has always been a little better for my setup.

    I’ve enabled logging and I’ve attached a txt file of my error log as an attachment. Basically the log amounts to the same scenario again and again for any page that is accessed:

    14:14:00 / No wp-cache file exists. Must generate a new one.
    14:14:00 / In WP Cache Phase 2
    14:14:00 / Setting up WordPress actions
    14:14:00 / Created output buffer
    14:14:01 / Output buffer callback
    14:14:01 / No closing html tag. Not caching.
    14:14:01 / wp_cache_shutdown_callback: collecting meta data.
    14:14:10 / No wp-cache file exists. Must generate a new one.
    14:14:10 / In WP Cache Phase 2
    14:14:10 / Setting up WordPress actions
    14:14:10 / Created output buffer
    14:14:10 / Output buffer callback
    14:14:10 / No closing html tag. Not caching.
    14:14:10 / wp_cache_shutdown_callback: collecting meta data.

    I’ve went through the FAQ for WP Super-Cache and checked their trouble shooting tips and nothing seems to work. I’m in the process of double checking again but I’m hoping someone has had this same issue and can help speed things up for me.

    Can someone anyone PLEASE HELP me get this figured out? I don’t know why upgrading to Swift Premium made this happen but this identical setup was fine using the free version of Swift.
    Since I already know WP Super Cache worked well (and I know how to configure it correctly) I wanted to stay with it over W3.

    #21386

    James B
    Member

    Previously when I checked the page source info for my site to see there was a note about caching successfully, there was nothing. Now I see this at the end of my page source code

    #21387

    James B
    Member

    Ok…I think I fixed it. I went into the footer.php file of the theme and added the closing tag that wasn’t there, immediately after the tag. I certainly don’t remember deleting it from the footer after I upgraded. Is this just a coding error Satish? Not saying I couldn’t have deleted it when I edited the footer…but I certainly don’t remember editing that far down in the footer after upgrading to Swift Premium.

    Worth a check anyway and hopefully that will help anyone who has this same problem!

    #21385

    Satish
    Keymaster

    It’s missing.
    Will be fixed in the next version, thank you :)

    #21388

    James B
    Member

    @Satish 5849 wrote:

    It’s missing.
    Will be fixed in the next version, thank you :)

    I’m glad I didn’t break it! I was pretty confident I didn’t accidentally delete it but I wanted to ask and confirm I wasn’t losing my mind!

    It’s always those little details that get you, lol! I’m glad that’s all it was.

    Although I did spend about 40 minutes making the solution ten times more complicated than it needed to be. When I finally got around to running debug and then I saw that message appear in the footer it didn’t take too long to dawn on me how easy of a fix it was.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.