Speed Up My Website

Forums Forums SWIFT Themes Support Speed Up My Website

This topic contains 5 replies, has 2 voices, and was last updated by  Thomas Von Ohlen 3 years, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
URL:
Version:
  • Author
    Posts
  • #15913

    My website runs extreamly slow. I hope that it is just because of the images on my site (even thought it is only 4 images and they are all optimized).

    In an effort to fix the speed issue I have decided to use amazon S3 and their cloud program. I have uploaded my images to their hosting center and have links ready to be put into the template but the template wont let me.

    Please tell me how I can add an external link for my “featured images” on posts as well as for my header image for the entire website. If I have to go into code that is fine but please tell me specifically how I can link these images.

    I am loosing visitors daily due to the slowness of my site.

    Thank you very much for your time.

    -Lily

    #20505

    Satish
    Keymaster

    I dont see problem with the images, is it possible for you to try a different hosting?

    #20506

    Satish
    Keymaster

    Your logo url is not set correctly, and I also think that some of the plugins you are using are messing with the site.

    1. Disable all plugins.
    2. Remove the logo from swift options, and upload it again.
    3. Activate the plugins one by one and check the site speed after each plugin is activated.

    #20507

    Satish
    Keymaster

    if you see the source code of your page, the value set as logo url is a very very long string..
    Which when saved as a text file taking 1.5MB.

    That is the reason for slow load time.

    #20508

    Satish,

    Thank you for getting back to me. I have removed the logo which has cut the load time in half however I still believe that it is taking too long. It is not an option for me to switch hosting accounts.

    You recommend using a CDN on your article about 90+ page rank on google. How do I do that if I can’t link out externally from the site? Please tell me how to link my header and my featured posts images to an image hosted somewhere else.

    Also, since I removed the logo on the home page it now shows “powerlifting for women” over my banner image which is not apart of my image. How would I remove that?

    Thanks again for your help.

    Lily

    #20509

    PLEASE HELP ME REMOVE THE NAME OF MY WEBSITE OVER THE TOP BANNER! PLEASE, this looks ridiculous and I don’t know why it is there or how to get rid of it. I appreciate your help.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.