Error messages when installing Swift 5.19 theme

Forums Forums SWIFT Themes Support Error messages when installing Swift 5.19 theme

This topic contains 5 replies, has 3 voices, and was last updated by  unicorn 4 years, 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
URL:
Version:
  • Author
    Posts
  • #15122

    newsmonkey
    Spectator

    I’ve had Swift 5.19 running perfectly on a testing server for a while, but I’ve just tried activating the theme in WordPress on another server and get the following series of error messages:

    Quote:
    Warning: copy() [function.copy]: open_basedir restriction in effect. File(/swift_default.jpg) is not within the allowed path(s): (/home/connexwn:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp) in /home/connexwn/public_html/wp-content/themes/SWIFT-v5.19/admin/admin-core.php on line 71

    Warning: copy(/swift_default.jpg) [function.copy]: failed to open stream: Operation not permitted in /home/connexwn/public_html/wp-content/themes/SWIFT-v5.19/admin/admin-core.php on line 71

    Warning: fopen() [function.fopen]: open_basedir restriction in effect. File(/swift_custom/timthumb.php) is not within the allowed path(s): (/home/connexwn:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp) in /home/connexwn/public_html/wp-content/themes/SWIFT-v5.19/admin/admin-core.php on line 83

    Warning: fopen(/swift_custom/timthumb.php) [function.fopen]: failed to open stream: Operation not permitted in /home/connexwn/public_html/wp-content/themes/SWIFT-v5.19/admin/admin-core.php on line 83

    Warning: fwrite(): supplied argument is not a valid stream resource in /home/connexwn/public_html/wp-content/themes/SWIFT-v5.19/admin/admin-core.php on line 87

    Warning: fopen() [function.fopen]: open_basedir restriction in effect. File(/swift_custom/custom-style.css) is not within the allowed path(s): (/home/connexwn:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp) in /home/connexwn/public_html/wp-content/themes/SWIFT-v5.19/admin/admin-core.php on line 91

    Warning: fopen(/swift_custom/custom-style.css) [function.fopen]: failed to open stream: Operation not permitted in /home/connexwn/public_html/wp-content/themes/SWIFT-v5.19/admin/admin-core.php on line 91

    Warning: fwrite(): supplied argument is not a valid stream resource in /home/connexwn/public_html/wp-content/themes/SWIFT-v5.19/admin/admin-core.php on line 95

    I’ve checked and the MySQL database user has full access rights to everything. What am I doing wrong?

    #18420

    newsmonkey
    Spectator

    My webhost insists this is a “coding issue” and nothing to do with their server settings.

    Quote:
    We have checked provided errors and see that the path to files which should be opened is not correct. For example in first error we can see that script “admin-core.php” trying to open file with path ‘/images/default.jpg’ , but this file is located in ‘~/public_html/wp-content/themes/SWIFT-v5.19/images/default.jpg’ You should set correct path to need files in your script to fix these problems.

    All I’ve done is install Swift from the ‘add themes’ option in WordPress and given (correct) FTP details. There’s no reason why other themes should work and this one doesn’t — or why this theme works on another server but not this one.

    Aagh.

    #18418

    Satish
    Keymaster

    open_basedir restriction in effect.

    Copy function is restricted on your server, ask your hosting company to remove the restriction. Tell them that SWIFT is used by thousands of people and it’s not a coding issue.

    #18419

    newsmonkey
    Spectator

    Thanks Satish. They’re a slippery bunch – these web hosts. Hopefully they’ll get their act together soon ..

    #18421

    newsmonkey
    Spectator

    The saga continues. Think I might need a new webhost:

    “Hello,

    it’s a theme issue. We’ve added debug info, and as you can see it tries to copy /home/connexwn/public_html/wp-content/themes/swift/images/default.jpg to /swift_default.jpg which is obviously incorrect, please check.

    Thanks “

    #18422

    unicorn
    Spectator

    @newsmonkey 1484 wrote:

    The saga continues. Think I might need a new webhost:

    “Hello,

    it’s a theme issue. We’ve added debug info, and as you can see it tries to copy /home/connexwn/public_html/wp-content/themes/swift/images/default.jpg to /swift_default.jpg which is obviously incorrect, please check.

    Thanks “

    what`s problem with this theme ? please specify it.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.