PDA

View Full Version : Problems with $swift_include_pages



hezumartin
11-03-2009, 05:32 AM
Hi!!


I have been hours and hours trying to find a solution for my problem but I couldn't find it!


It is just that the maximum number of pages to show in the header is set to four, but I don't know why, I installed again the theme from a backup when it didn't happen but still there, only four buttons (Home+3pages). I want to show all pages, just 5! Please help!


Thanks!!!

Satish
11-03-2009, 01:58 PM
http://swiftthemes.com/2009/09/wordpress-themes/a-complete-guide-to-installing-and-customizing-swift/



Navigation Pages: Here you get the option to choose the pages that appear in the top navigation area. You should enter the page idís separated by comma (Check the screenshot below) . 6 pages are shown by default.

hezumartin
11-06-2009, 09:38 AM
Thanks a lot, but that doesn't solve my problem, I tried everything. I even reinstalled wordpress and started it all again (it is a new website) but (and I didn't realize it) now it only appears the home link and two more pages. No matter what I write in the theme options, I try to deactivate plugins but nothing fix it.


What can I do?


Thank you very much, swift is by far the best theme I found on Wordpress

hezumartin
11-06-2009, 10:12 AM
I finally solved it!!! In the header.php I found this code:


$query='&number=5&depth=1&title_li=';

wp_list_pages($query); ?>


I just deleted &number=5 and then all my pages were shown again on the header. Maybe it's due to subpages? I don't know but this is my first small workaround! I feel fine!


Thanks!