version 4.0.1 is out with bug fixes and 2 new features which are not found even in premium themes

Hello Switlers,
Along with bug fixes related to custom colours, I have two new features for you in SWIFT.
As there were several requests asking to support images from other hosts, I found a work around for it. SWIFT now downloads the first image in your post and saves it to wp-content/swift_uploads folder in case if its from other host and use it for generating thumbnails. A feature thats not present in any premium themes :D.
Note:Use this feature with caution. If you are hotlinking copyrighted images in your post, they might be downloaded on to your server and that may get you in to copyright troubles (Though it is very rare). To avoid such problems specify a different image in custom fields with key “image” when ever you are posting copyrighted images.
Another new feature thats added is auto resizing of images that over flow from the content area. This comes in very handy if you are moving to SWIFT from theme which has wider post area.

download Swift-v4.0.1

81 thoughts on “version 4.0.1 is out with bug fixes and 2 new features which are not found even in premium themes

  1. I want featured.php customized to fit my needs. I wanted to hyperlink the images so that when a user clicks the image,it moves to that post.Thank Satish for the excellent work, I love the theme and of all its free and works as well as a bonus track

  2. I have Swift v4.1.4 installed.  First time I am using the banner advertisements on the sidebar.  However, when click on enable in the Ad Management section, no adverts appear.  What am I doing wrong? 

  3. Occasionally my page uses the first picture in the page to generate the thumbnail and occasionally it doesn’t – I cannot figure out why. It doesn’t seem to have anything to do with size, type of image, or anything else I can think of.

    Also, is it possible to replace the default “colored pencil” image with something else?

  4. Hi Satish,

    Very nice theme.  Thank you. I intend to leave you coffee money!

    How can I change the header graphic?  I created a new graphic, 885 x 124 pixels. Is this what your instructions call a “logo” graphic?

    It’s confusing because next the instructions talk about modifying the header graphic dimensions, so I can tell if you and I are simply using different terminology.

    Please advise.  Thanks.

     – Peter

  5. Dear All,
     
    I have problem in this themes if the admin can solve it this is my web site
    http://allnewthings.com/
     

  6. Changes made to the CSS are not applying. I have done the chmod, and I check the button every time, but no go.

    • Did you check enable custom colours option??

      • uh….*sheepish* that did it. I missed the obvious.
        BTW, why so much tick marking for the customization? I mean, I wouldn’t be doing it unless I wanted to customize, right? Plus restore defaults is always a possibility…
        Another thing. You say version 4.0.1 is out, and it seems to be the latest from this blog, and obviously you are active here. My wordpress auto-installed 4.1.something. So what’s the secret? You forgot to announce the update, or it changes numbers after installing, or what?

        • 1.A person using custom css may not use custom colours, and other fellow may just want to change the layout keeping the default colour scheme. SWIFT is not custom made for you, I have to accomodate needs of every possible user.

          2.Only major updates are announced on this blog.

  7. One more little question about hotlinks. I’m part of an affiliate program and when I want to post about a product they give me the code which includes the description and the image. I don’t have to save it to my server. When I post such content, it is saving the image to “swift_custom”, but it’s not showing as a thumbnail on my main page. How do I fix that?

    • Didn’t I say that was my last question? LOL Still having trouble with remote images, but I’m working around it having to use the provided image links from my affiliate programs by also uploading the image to my site and adding it into the image meta with the post.
      New question – I had a category with the slug of family-happenings and that is the category I chose to use in the slider. I decided to rename my categories using one word slugs, so I renamed that one to just family, but upon doing so that category stopped showing in the slider, nor would any others I have with one word slugs. If I renamed them again to more than one word any I put in there worked fine. Is there a fix for that…so I can use the one word slugs?
      Thank you again for a great theme!
       

    • Give me the link to the post in question.

      • Sorry this took me so long! I didn’t realized you’d replied. *blush*
        Ok here’s an example to my rave reviews section:
        http://huffmasterfamily.com/category/favorite-products/our-reviews/
        The first post that shows up just has a little blue box if you are viewing in FF, or a box with an X if in IE.
        The post itself looks fine, but you can see in the post there is an image of a product that is part of my affiliate link.  When I go in to edit I see that it’s grabbed this link http://huffmasterfamily.com/wp-content/swift_custom/1263.jpg and put it into the meta info as it should, but it doesn’t show up on my site even though permissions are correct.  Also when you go to that image link, the image is there, so that’s not a problem either.
        Here is something that “may” be part of the problem. Back on the archive page just looking at the little blue box with nothing in it,when I right click and choose view image it takes me here:
        http://huffmasterfamily.com/wp-content/themes/swift/timthumb.php?src=http://huffmasterfamily.com/wp-content/swift_custom/1263.jpg&h=90&w=180&zc=1
        And on the page itself it says:
        Unable to open image : /home/huffmast/public_html/huffmasterfamily.com//wp-content/swift_custom/1263.jpg
        If you’ll notice there are 2 forward slashes between .com and wp-content. Not sure if that matters or not but thought I would mention it and thanks in advance for your help! I’m also clicking to notify me via email of comments! LOL
         
         
         
         
         
         

        • GD library doesnt support some jpg formats (They are very rare).

          As this is the only post in question, uplaod a different image and update the custom image url.

          You have made very very good use of SWIFT, keep up the good work. I will try to add showcase feature on swift blog along with the release of v5.0

  8. Hi Satish,
    Thankyou very much.  It worked fine.
    Is there a plan to implement tags and categories to apply to pages too?
    Thanks
    Michael

  9. Hi Satish
    I just gave up on 4.0.1 as I still couldn’t get the background colour to change. I decided to try 4.1.0 instead, but that has difficulties too. The current problems I have, for your info, are:
    1) Body background colour still won’t change – all other colours change fine
    2) No images showing up at all.
    So I’m back to my lovely stable 3.1.9.3 again!
    Any suggestions? Or should I just wait for 5?!

    • Sheridan,
      I still have one of my blogs at level 3.1.9 – it is working great with colors and images.  My other blog is at 4.0.1 as yours and I am having exactly the same issues as you… the body background will not change like the other color settings , the slider is showing broken images no matter what I do with adding the image to custom fields.  How do I get version 3.1.9.3 again ? I would like to install that version until something more stable is available.  Thanks

  10. Hi, I recently got swift theme 4.1 and my host is godaddy.  My problem is I can’t change colors on anything. The check boxes under swift theme/home page options and on colors page don’t appear at all. So there is no box to enable custom colors. I tried changing permissions but with godaddy I can only change to read write or execute. Maybe it is still permissions problem? I did try to update the create-styles.php and full-width.css like suggested  in the forum re:bugs and that didn’t work either. Any ideas how to fix??  Thanks!

  11. I’m having the same problem George was having with the background color. All my other colors are as they are supposed to be, but the body background won’t go to anything but white.
    Can anyone share how to fix that? Also what if I wanted to use a background image instead of a color…could that be done as well?
    Great theme by the way…no AWESOME theme! LOL

    • Dawn,
      I spent quite a bit of time last night trying to look at the css code.  I had No luck with changing the body background color to anything different than white.  What I decided to do was just add a line of code to have it go to an image instead.  I went to appearance editor and select theme to edit swift on the top right pulldown.  Then look to the right and you should see a list of php files.  Go almost all the way down until you see custom-style.css.  I added this code to the very beginning of the file and saved.  Just need to make sure your background image is in the correct directory.  Hope that helps… Great Theme !  http://giftideasforchristmasguide.com

  12. i have problem with color change… how can i change the button’s border colour in the header bar??

  13. How (if at all) can I get rid of the white bars on the sides? I want my home page background to all be the same color, not the color in the middle but white on the sides. I can’t find any option that would allow me to get rid of the white (for the record, I know next to nothing about CSS).

  14. hi,

    i need help. thumbnails are not showing on the mainpage.  what should be the problem?

  15. Hi Satish – I just tried version 4.8 and had several problems:
    1) the slider has nothing in it at all (regardless of which category I choose – they all have plenty of posts)
    2) the thumbnails are all rectangular (they used to be square)
    3) although I can see my custom colours in the “colours” editor, they will not apply to the theme despite ticking to enable css changes. I am scared to select another colour theme in case I lose my custom colours!
    Unfortunately when I returned to version 3 there were still no posts in the slider and I can’t seem to get them back whatever I try. Aaaargh! Help please!

    • The posts not showing appears to be because I have renamed some of my categories. The slider can only find posts whose categories have never been renamed. How can I fix this?

    • One further problem -
      4) The Popular posts show up in version 3 but not in version 4 – I just get a blank panel

    • Great Theme, however, I have the same 4.8 issues as you – not much I could do but go back to version 4.02 – seems to be a more stable – I can get my css custom color changes to work however my body background color will not and is always set to white.  Sharing your pain… hope Satish will get back to us soon

    • 1.Choose a featured category and number of featured posts from options page.
      2.Are rectangular thumbnail a problem??
      3.Check the rewrite custom-styles.css box when you save changes.

      • Satish,  Yes I have choose a featured category and number of featured posts from options page for a while.  Does not fix the images not showing in the slider.  I also added them to the custom fields for each post as “image” http://giftideasforchristmasguide.com/wp-content/swift_custom/94.jpg
        2. I think the rectangular thumbnail is a problem because it seems to be taking up more space in the slider – not a high priority for me yet.
        3. Yes I always Check the rewrite custom-styles.css box when I save my custom color changes.  The problem is the only one which does not change colors (which is my most important) is the body background color, which is always white – I have tried to change the body background color to several other colors but it does not change anything on my website.  Your Quick help is appreciated.

      • 1. Choose a featured category and number of featured posts from options page.
        Yes, I do that, but it only works if I have never changed the category name. For any category where I have renamed the category it will not work. (Incidentally I have kept the slug names the same). I am using permalinks and guess that may be affecting things.
        2. Are rectangular thumbnail a problem??
        Yes, they are cropping the tops and bottoms of images. Very unsightly when for example the image is a book cover, or a model where all you can see of her face is the nose and mouth! I much prefer thumbnails which remain in proportion.
        3. Check the rewrite custom-styles.css box when you save changes.
        Yes, I do that. It still soesn’t work. Is it a permissions thing?

  16. Satish,
    I have this error”Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File…..”
    SO , I tried to exclude lines in timbthumb:
    // if (file_exists($path . $src)) {
     //  return $path;
     // }
    lines 567/8/9
    and now working, I must to test it again, but for now it’s ok

    all for your info, tks u for now
    bye

  17. Help – installed 4.07 and body background color will not change from white to dark green – all the other css colors seem to be changing great.  Can you help with the body background.  Thanks   http://giftideasforchristmasguide.com

  18. on my slider only last post picture and text is showing. and page  any 1 guide me how can i will fix it? 

  19. Eeek! I upgraded wordpress & swift and now I wish I would have not… having problems so hopefully you can help– my site looked perfect before :(
    When I try to customize things, I get a problem loading page error once I click save.
    I cannot get my custom settings such as colors to work.
    I did try to change my permissions of the folders suggested, but I’m not sure they really worked.  Is this perhaps my problem?

  20. No Changelog for 4.0.2? Please keep a online or updated offline changelog for your theme.

  21. Problem with new themes… error in wp-includes class.simplepie.php…

  22. Downloaded and test.
    No change when I choose between “Full width header / 960px header”  in layout option :-??
     

  23. images in slider doesn’t show. in layout Magzine no images, in layout Blog yes. 
    in 3.9 was all ok.
    maybe i’ll try with 4.1
     

    • Is GD library enabled on your host??
      Ask your hosting support.
      Thumbnail resize script requires gd library.

      • I have the same issue.  In my 3.1 version of swift all the images related to posts  show up correctly in the slider – here is the code:
        <a rel=”nofollow” href=”http://www.amazon.com/Presentation-Secrets-Steve-Jobs-Insanely/dp/0071636080%3FSubscriptionId%3DAKIAJVSG7VP54PMZLMPA%26tag%3Dcretedirectsolutions-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3D0071636080″><img style=”float:left;margin: 0 20px 10px 0;” src=”http://ecx.images-amazon.com/images/I/4173s6m5hNL._SL160_.jpg” alt=”" /></a>
        In my other blog updated to version 4 of Swift I have the same type of code but the images do not show in the slider:
        <a rel=”nofollow” href=”http://www.amazon.com/Wii-Beatles-Rock-Band-Software-Nintendo/dp/B001TOQ8LG%3FSubscriptionId%3DAKIAJVSG7VP54PMZLMPA%26tag%3Dgift-ideas-for-christmas-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB001TOQ8LG”><img style=”float:left;margin: 0 20px 10px 0;” src=”http://giftideasforchristmasguide.com/wp-content/uploads/2009/11/51pjmporQCL._SL160_.jpg” alt=”The Beatles Rock Band Software” /></a>
        Actually swift is extracting the url link and not the url image link. When I right click properties, the broken link on the slider image shows : http://www.amazon.com/Wii-Beatles-Rock-Band-Software-Nintendo/dp/B001TOQ8LG%3FSubscriptionId%3DAKIAJVSG7VP54PMZLMPA%26tag%3Dgif

  24. Great!!! Congratulations for your theme

  25. thanks for this themes. its awesome.

  26. thanks satish it very helpfull

  27. One more suggestion especially keeping in view user navigation and seo, There should be a template for sitemap so that users can add a html sitemap by adding a new page and chosing sitemap template for it. I have seen such features in flexx themes.

Leave a Reply

Your email address will not be published. Required fields are marked *